Launched the SSR via cloud formation template (SSR version = 6.1.8)
The SSR VM is up and running
The end user is able to ssh to it from his laptop
SSR showed up on inventory
but SSR software is not downloaded even after waiting for 2 hours
The problem was that they had a private DNS on their VPC (DHCP options set on VPC)
That DNS being unavailable during initial VM bootup cause the cloud-init to fail.
The fix is to make sure that DNS is available during first VM boot.
Steps: