On Juniper Networks Devices, when more than 256 VLANs as name tags are added on the same interface VLAN will not get added to the interface for which dcd crashes and generate core resulting in traffic loss.
To check the core files, execute the CLI command:root@switch> show system core-dumps
The following commit error can be seen:
root@switch# commit check
Message from syslogd@LAB-DEVICE at Feb 25 23:59:36 ...
LAB-DEVICE[7474]: ../../../../../../src/junos/sbin/dcd/infra/db-param/param_access.c:dcd_param_set_iff_ptr_value:2248: insist 'len <= iff_obj_maxlen[param_ix]' failed
DCD commit check failed
DCD commit check process dumped core
error: configuration check-out failed
A core-dump for dcd demon is generated after every commit attempt:root@switch> show system core-dumpsfpc0:---------------------------------------------------------------------------rw-rw---- 1 root field 6907354 Feb 25 23:58 /var/tmp/dcd.core.0.gz-rw-rw---- 1 root field 6109503 Feb 25 23:59 /var/tmp/dcd.core.1.gztotal files: 2
As a workaround use vlan-ids instead of vlan name tags while adding vlans to an interface. This issue is being tracked and solved by PR1696428.
It would be required to upload RSI, logs and the core-dumps to the JTAC case to confirm a match for this issue.
For further reference, please review the following documentation:
PR1696428 - Adding more than 256 VLANs as name tags on the same interface results in dcd crashhttps://prsearch.juniper.net/problemreport/PR1696428
06/07/23-rfallasguzma: Creation
https://prsearch.juniper.net/problemreport/PR1696428