Description

After performing an RMA with Lanner, users are unable to login using the admin user.

 

When the user tries to switch to the admin user from root, they receive the following error indicating that the user does not exist:

 

# su admin

su: user admin does not exist

 

Manually adding the entry to /etc/passwd and /etc/shadow fails

Changing the password via linux passwd fails.

Symptoms

Unable to login with Admin user acount

Solution

This was an RMA from Lanner, and customers get these with the right software version requested on it, in this case 6.2.9-5.lts.el7. It appears this could be an issue on their end with the imaging. So, these are the options to resolve:

 

  1. Factory reset: syntax is restore system factory-default [force] [router <router>] [node <node>] [<mode>] and here is the documentation:
    1. https://www.juniper.net/documentation/us/en/software/session-smart-router/docs/config-factory-reset/index.html
  2. Reimage via usb and here is the documentation:
    1. https://www.juniper.net/documentation/us/en/software/session-smart-router/docs/intro_creating_bootable_usb/
  3. RMA with Lanner

RMA replacement of the box resolved the issue.

Modification History

2026-08-20 : Article Created