After performing an RMA with Lanner, users are unable to login using the admin user.
When the user tries to switch to the admin user from root, they receive the following error indicating that the user does not exist:
# su admin
su: user admin does not exist
Manually adding the entry to /etc/passwd and /etc/shadow fails
Changing the password via linux passwd fails.
Unable to login with Admin user acount
This was an RMA from Lanner, and customers get these with the right software version requested on it, in this case 6.2.9-5.lts.el7. It appears this could be an issue on their end with the imaging. So, these are the options to resolve:
RMA replacement of the box resolved the issue.