This article provides a possible solution when an AWS vSRX fails to be adopted in Security Director Cloud.
By default, the AWS vSRX is created with user-generated keys and might not allow SSH login using a password.
If the device configuration includes 'groups aws-default system services ssh no-passwords', the device will fail to be adopted by Security Director Cloud.
To address the problem, execute and commit the following commands at the vSRX CLI level:
delete groups aws-default system services ssh no-passwords
set groups aws-default system services ssh authentication-order password